Bonjour

Il peut arriver que vous ayez écrit une fonction SI assez longue dû au grand nombre de conditions. Bien souvent ce type de fonction est difficile à suivre. Dès fois on peut la simplifier en utilisant intelligemment une fonction matricielle ou une fonction de recherche.

Prenons le cas ci-dessous:

 

liste produit

 

Il s’agit d’une liste de produits sur laquelle on applique une réduction, l’objectif sera de choisir un produit en cellule D4 et en E4 écrire une formule qui dit si le produit choisi en D4 fait partie des produits avec réduction.

 

objectif

 

Si vous utilisez simplement la fonction SI avec OU, vous aurez ce résultat:

=SI(OU(D3=B3;D3=B4;D3=B5;D3=B6;D3=B7);”Réduction”;”Pas de réduction”)

Le problème avec cette formule est que si la liste des produits augmente, alors votre formule devra tout aussi augmenter.

 

L’une des solutions sera d’utiliser la formule matricielle qui suit:

=SI(OU(D3=B3:B7);”Réduction”;”Pas de réduction”) n’oubliez surtout pas de valider avec la Ctrl+ Shift+ Entrer

 

L’autre solution sera d’utiliser la fonction EQUIV imbriquée dans la fonction SIERREUR:

=SI(ESTERREUR(EQUIV(D3;$B$3:$B$7;0));”Pas de réduction”;”Réduction”)

 

Pour en savoir plus sur:

 

Pour maîtriser toutes les fonctions Excel n’hésitez pas à télécharger votre formation complète sur les fonctions Excel en cliquant ici.

Bases et fonctions

Share This