Bonjour

Plusieurs d’entre vous utilisent la fonction SI pour résoudre certains problèmes dans Excel. Pour les plus avancés, ils imbriquent même plusieurs SI dans leurs formules. Mais il faut tout de même savoir que dans certains cas, on peut bien se passer de cette jolie fonction.

 

Cas 1: on teste si une cellule est vide

Dans certains cas de formule nous avons besoin de tester si une cellule est vide et si oui alors renvoie autre chose. Dans mon cas, je mets souvent le vide. Je m’explique si je fais une formule dans la cellule A5 j’écris =A1, si A1 est vide le résultat sera 0, évidemment mon objectif est d’avoir résultat de vide et non de zéro, comment le résoudre ?

Avec la fonction SI

Pour résoudre cela avec la fonction SI, j’aurai écris dans A5: =SI(ESTVIDE(A1);””;A1) par exemple.

 

Sans la fonction SI

J’utilise la formule  =REPT(A1;NBCAR(A1)>0)

Il faut noter ici que NBCAR(A1)>0 rendra comme résultat FAUX ou VRAI. Ces valeurs correspondent à 0 pour FAUX et 1 pour VRAI.

 

Cas 2: on teste la valeur et renvoie une autre parmi plusieurs autres

Prenons le cas ci-dessous, nous voulons donner une mention selon la note d’un candidat

note

Pour retrouver la mention

Avec la fonction SI

SI_mention

 

Sans la fonction SI:

=INDEX($D$6:$D$10;EQUIV(C2;$C$6:$C$10;-1))

Un autre exemple ici

Cas 3: … heu j’ai oublié 🙂

Et vous connaissez vous d’autres cas dans lesquels cette fonction n’est pas obligatoire?

 

Share This