Hello

J’espère que vous allez bien.

Vous êtes-vous déjà demandé ce que serait la vie dans Excel dans TCD (tableaux croisés dynamiques) ? Je sais que certains ne savent toujours pas utiliser les TCD dans Excel et j’en suis vraiment désolé.

Dans cet article on verra un cas pratique assez intéressant qui fait partie des nouvelles formations présentes dans ma formation Excel de A à  Z. On va voir quelle est la différence entre une solution avec les formules et une solution avec les TCD.

Nos données :

Prenons notre base de données :

L’objectif de notre cas :

Nous voulons retrouver les revenus par produit et par région.

Pour le faire nous allons utiliser 2 approches :

L’approche avec les formules :

Ici nous allons utiliser les nouvelles formules matricielles qui sont extrêmement puissantes.

1.     Retrouver les listes uniques des régions et des produits

Pour cela nous allons utiliser les fonctions :

  • UNIQUE() c’est une fonction matricielle qui renvoie les valeurs uniques d’une plage ou même d’un tableau
  • TRIER() permet de tout simple de trier une plage donnée
  • TRANSPOSE() permet de transposer une plage ou un tableau (fonction matricielle)

La liste unique des régions :

  • En K2 on insère la formule : =TRIER(UNIQUE(B2:B564))
  • Valider, le résultat se propage sur toute la colonne
  • Voici le résultat :

La liste unique des produits :

  • En L1 on insère la formule : =TRANSPOSE(TRIER(UNIQUE(C2:C564)))
  • Valider, le résultat se propage directement sur toute la ligne
  • Voici le résultat :

La fonction transpose permet de mettre le résultat en ligne

2.     Retrouver les revenus par région et par produit

Pour cela nous allons utiliser

  • la fonction SOMME.SI.ENS()
  • les références implicites qui permettent automatiquement de choisir successivement les cellules d’une même matrice

Voici la formule

  • En L2 écrire : =SOMME.SI.ENS(G2:G564;C2:C564;L1#;B2:B564;K2#)
  • Valider, le résultat se propage automatiquement sur tout le tableau
  • Voici le résultat

L’approche avec un tcd :

Avec un tableau croisé dynamique, c’est assez facile.

  • Se mettre sur une des cellules du tableau
  • Aller dans le ruban, Insertion/Tableaux/Tableau croisé dynamique
  • Cliquer sur OK
  • Dans le TCD, il suffira de mettre les éléments comme ci-dessous pour avoir le résultat

Conclusion

La vie est bien plus facile avec les TCD

Share This