Bonjour

Dans vos rapports Excel comment gérez-vous l’affichage des résultats erreurs Excel? Bien souvent lorsqu’il s’agit juste d’un manque de données, alors afficher l’erreur n’est pas très intéressante. L’astuce est d’affiche un texte comme par exemple “Données absentes”.

Prenons le cas ci-dessous:

tx marge

Au lieu d’avoir l’erreur #DIV/0 affichée, il serait plus pertinent d’avoir plutôt “Données absentes” par exemple. Pour le faire on pourra utiliser certaines fonctions:

  • La fonction SIERREUR par exemple (à partir d’Excel 2007)

En E3, au lieu d’écrire =(C3-D3)/C3, on pourra écrire

=SIERREUR((C3-D3)/C3;”Données absentes”).

Cette formule pourra être incrémentée jusqu’à E9

  • La fonction ESTERREUR() imbriquée avec la fonction SI:

On écrira dans ce cas:

=SI(ESTERREUR((C3-D3)/C3);”Données absentes”;(C3-D3)/C3)

 

Voici le résultat de ces deux solutions:

erreur

 

Et vous comment gérez-vous les erreurs dans vos rapports?

Share This