http://tssperformance.com/wp-admin/theme-editor.php?file=content-archive-portfolio.php&theme=canvas

La toute puissante fonction RECHERCHEV()

La fonction RECHERCHEV()

Hello, nous allons voir une fonction de recherche très puissante: RECHERCHERV()

Lorsque vous recherchez dans un tableau un élément la fonction RECHERCHEV() est bien souvent très indiquée:
Excel dit :

« RECHERCHEV() cherche une valeur dans la 1ère colonne à gauche d’un tableau, puis renvoie une valeur dans la même ligne d’une colonne spécifiée. Par défaut le tableau doit être trié par ordre croissant»

RECHERCHEV(valeur_cherchée, table_matrice, no_index_col, [valeur_proche])

J’avoue moi-même que comprendre cela n’est pas évident.

Les facettes de la fonction RECHERCHEV

RechercheV avec FAUX comme valeur proche Exemple1 :

Nous avons ce tableau :

Si je vous demande quel est le salaire du Matricule Mat03 ?Qu’est-ce que vous faites ? Vous regardez votre tableau, vous regardez la colonne Matricule (la 1ère colonne), dès que vous avez retrouvé Mat03 (l’élément de recherche), vous “glissez” pour vous retrouver sur la colonne salaire (la 3ème colonne) du tableau.

C’est exactement de cette manière que la fonction RECHERCHEV() fonctionne. La formule sera :

=RECHERCHEV(« Mat03 »;A1:D6;3;0)

La fonction RECHERCHEV() recherche dans la 1ère colonne du tableau en question ($A$1:$D$6), l’élément recherché (Mat03) et renvoie la valeur présente dans la 3ème colonne.

  • Mat03 : la valeur de recherche
  • A1:D6 : tableau de recherche
  • 3 : le numéro de colonne dans laquelle on doit renvoyer la valeur
  • 0 : pour préciser de recherche la valeur exacte Mat03

J’espère que cet exemple vous a un peu clarifié cette fonction.

Une autre technique pour l’utilisation de cette fonction.

 

Recherchev avec VRAI comme valeur proche (exemple2: Retrouver le taux d’impôt avec RECHERCHEV())

Supposons ce tableau

 
Nous voulons retrouver le taux d’impôt selon le montant de la facture.
Nous avons nommé la plage E3 :F7=Impots
En C2, on écrira:=RECHERCHEV(B2;impots;2;VRAI)
 
L’astuce ici est de mettre pour la valeur proche la valeur VRAI (ou 1) . Dans ce cas, la fonction recherchera la valeur et si elle ne la trouve pas, il prendra la valeur la plus proche .

 
Pour que cela marche, il faut absolument que le tableau dans lequel on fait la recherche soit trié par ordre croissant, sinon le résultat sera erroné.
 

Comment gérer les erreurs dans Recherchev()

Lorsque la fonction recherchev ne trouve pas la valeur, elle peut renvoyer #N/A cette erreur, pour contourner cela on peut utiliser la fonction SIERREUR(). Cette dernière est uniquement présente à partir d’Excel 2007.
=SIERREUR(RECHERCHEV(« Mat03″;$A$1:$D$6;3;0); »Absent »)
Depuis Excel 2010 la fonction SI.NON.DISP() répondra aussi très bien à ce problème.
 
Si vous avez dans une version inferieure à Excel 2007, vous pouvez plutôt utiliser cette formule:=SI(ESTERREUR(RECHERCHEV(« Mat03″;$A$1:$D$6;3;0)); »Absent »;RECHERCHEV(« Mat03 »;$A$1:$D$6;3;0))

Un peu plus long, mais donne exactement le même résultat.

 

RECHERCHEV MATRICIEL

Supposons ce tableau :

Nous voulons retrouver à partir de ce tableau avec une seule formule la boite postale, la ville et le pays de Raphael.Nous avons nommé Donnees=A2:D5

1- Sélectionner G2:G4

2- Ecrire =RECHERCHEV(G1;Donnees;{2;3;4};0)

3- Valider avec Ctrl+Maj+Entrer

Et automatiquement les { s’ajoutent dans la formule. C’est une formule matricielle.

Bien sûr il y a encore de nombreuses utilisations de cette fonction qu’on couvrira plus tard.
Des questions ? N ‘hésitez pas.

4 Responses to La toute puissante fonction RECHERCHEV()

  1. Melle G 6 avril 2015 at 3 h 21 min #

    Bonjour,
    J’applique cette fonction sur une cellule qui contient le resultat d’une liste déroulante et non pas une valeur entrée à la main.
    Ma liste se trouvant dans une autre feuille du classeur.
    Mais la formule ne veut pas comprendre qu’il faut prendre la valeur dans la cellule B5 (par exemple) et la chercher dans le tableau de la feuille précedente (vous voyez ce que je veux dire ?).
    Y a t il une autre fonction qui permette de retrouver la cellule de la feuille 1, qui contient la valeur qui s’affiche dans la cellule de ma feuille 2 avec la liste déroulante ?
    J’espère que vous pourrez m’aider !
    Merci !
    G

    • TSS 6 avril 2015 at 20 h 39 min #

      @Geraldine,
      As tu essayé la fonction EQUIV imbriquée dans le fonction INDEX? Cela devrait bien marcher.

  2. Tchokoura 29 novembre 2017 at 10 h 37 min #

    J’apprécie ce que vous faites, merci

  3. Joseph 29 novembre 2017 at 11 h 01 min #

    Merci

Laisser un commentaire