http://tssperformance.com/wp-admin/theme-editor.php?file=content-archive-portfolio.php&theme=canvas

Construire un calendrier dans Excel -partie 1: génerer avec une formule matricielle qui renvoie Janvier jusqu’à Décembre

Hello

J’ai une gentille astuce à vous présenter dans Excel. Cette astuce nous aidera ensuite à créer un calendrier automatique dans Excel. En général lorsqu’on veut générer les mois dans Excel on écrit dans une cellule « Janvier » et ensuite on incrémente vers le bas. Aujourd’hui on verra comment le faire avec une formule matricielle.

Le problème:

Ok, je reprends on veut juste faire une formule qui écrive automatiquement Janvier jusqu’à Décembre dans 12 cellules d’une seule colonne. Ne me demandez pas pourquoi on aurait besoin de le faire…Vous le saurez dans 2 articles.

 

La solution:

Pour résoudre ce cas, nous allons utiliser les formules matricielles. Avant de donner la solution, on ira étape par étape pour bien comprendre. En fait nous allons utiliser trois fonctions différentes: LIGNE(), DATE() et TEXTE().

Etape 1, bien comprendre la fonction LIGNE():

La fonction ligne permet de donner le numéro de ligne d’une colonne. Nous allons utiliser cette fonction de manière matricielle (juste pour comprendre).

  • Sélectionnez 12 cellules dans une colonne, par exemple A3:A14;
  • Ecrire =LIGNE(1:12)
  • Valider avec Ctrl+Shift+Entré
  • Le résultat est 1, 2, 3…12 dans chacune des cellules

 

Etape 2, comprendre la fonction DATE():

Assez simple, elle permet d’avoir la date en précisant l’année, le mois et le jour. En d’autres termes si j’écris =DATE(2017;12;31), j’aurai comme résultat 31/12/2017 dans la cellule.

 

Etape 3, comprendre la fonction TEXTE:

La fonction TEXTE vous permet de modifier la manière dont un nombre est affiché en lui appliquant une mise en forme qui utilise des codes de format. On peut donc décider d’afficher une date sous un format « mmmm » qui représente en fait le mois.

Donc si j’écris dans une cellule Excel =TEXTE(DATE(2017;12;31); »mmmm »), j’aurai comme résultat décembre

 

Le tout en un:

Bon allons y… voici la solution à notre problème:

  • Sélectionner 12 cellules d’une même colonne;
  • Ecrire (ne tenez pas compte des accolades, ils viendront plus tard):

  • valider avec Ctrl+Shift+Maj

Et le résultat y est: janvier, février…décembre.

, , , ,

4 Responses to Construire un calendrier dans Excel -partie 1: génerer avec une formule matricielle qui renvoie Janvier jusqu’à Décembre

  1. jmc 14 décembre 2017 at 9 h 46 min #

    Bonjour

    =mois(ligne(xx)) ça marche aussi, avec xx = référence que l’on souhaite

    • TSS 14 décembre 2017 at 10 h 27 min #

      @Jean-Marie, merci pour la contribution

  2. ousmane 20 décembre 2017 at 12 h 15 min #

    Bonjour

    Merci pour ces partages!!!
    tu peux rajouter la fonction « NOMPROPRE »
    =NOMPROPRE(TEXTE(DATE(2017;LIGNE(1:12);1); »mmmm »)) pour avoir Janvier, Février …)

    • TSS 21 décembre 2017 at 7 h 22 min #

      @Ousmane,
      Super, merci

Laisser un commentaire