http://tssperformance.com/wp-admin/theme-editor.php?file=content-archive-portfolio.php&theme=canvas

Comment vos ventes annuelles sont-elles réparties?

Bonjour

Je vous propose aujourd’hui un sympathique graphique dynamique pour représenter la répartition de vos ventes annuellement. Voici à quoi il ressemble:

Mise à jour avec une vidéo (29/01/2015)

Pour le faire, il faudra être un peu astucieux avec Excel, et peut-être qu’un peu de café ne fera pas de mal.

Déjà voici les données utilisées pour le faire:

Description du graphique:

 

Il faut noter ici qu’il s’agit d’un graphique avec 4 séries de données représentées en aire 2D. Ces séries sont représentées 2 à la fois:

Une série représente le total global des ventes (transparents)

Une série dynamique qui dépend du choix qu’on fait.

 

Pour faire ce graphique:

D’abord, il nous faut donc un autre tableau qui représente uniquement les 2 séries choisies: un tableau dynamique ;

Faire le graphique de ce tableau

 

Mise en place du graphique:

 

Création du tableau dynamique

Ce tableau doit faire apparaître seulement deux séries de données à la fois. Nous utiliserons les boutons radios:

 

Insertion des boutons radios

Dans l’onglet Développeur/Insérer/Case d’option, Changer le nom par défaut et mettre Produit1 en cliquant à l’intérieur du nom.

Paramétrer la case d’option: cliquer avec le bouton droit de la souris sur le bouton, choisir Format de contrôle. Dans la nouvelle boite de dialogue, dans l’onglet Contrôle, cellule liée, choisir A1 par exemple.

Créer les autres cases d’option: copier la case produit1 et coller juste à côté. Créer ainsi 3 autres cases d’options avec les noms Produit2, Produit3 et Total

 

Les boutons radios que nous venons d’insérer nous permettent de changer la valeur de la cellule A1 qui varie de 1 à 4 selon que clique sur la case d’option Produit1…Total.

Nous allons maintenant créer notre nouveau tableau qui dépendra de la cellule A1 donc des cases d’options.

 

Nous allons simplement reprendre les mois à partir de B18 jusqu’en B29;

En C17 écrire: =SI($A$1=1;C3; » »). Ensuite copier cette formule jusqu’en C29;

En D17 écrire: =SI($A$1=2;D3; » ») Ensuite copier cette formule jusqu’en D29;

En E17 écrire: =SI($A$1=3;E3; » ») Ensuite copier cette formule jusqu’en E29;

En F17 écrire: =SI($A$1=2;F3; » ») Ensuite copier cette formule jusqu’en F29;

Nous allons rajouter une colonne qui représentera le total transparent: en G17 écrire total transparent, en G18 écrire F4 et copier la formule jusqu’en G29

 

Si tout a été bien fait vous devriez avoir un tableau comme celui-ci-dessous:

Création du graphique

Sélectionner B18:G29, dans le ruban, insertion/Graphiques/Aires/Aires 2D, choisir le 1er

En ce moment, vous avez l’impression qu’il y a juste une seule série qui est représentée. Ne soyez pas inquiet, les deux séries sont représentées, mais la série la plus grande (total transparent) est mis en avant.

 

 » Allé une gorgée de café peut-être? »

 

Nous allons rendre transparent la série total transparent: cliquer dessus avec le bouton droit de la souris, cliquer sur Mettre en forme la série de données.

Dans la boite de dialogue, dans l’onglet Remplissage, choisir remplissage uni. Dans couleur de remplissage, choisir une couleur assez claire et augmenter le niveau de transparence à au moins 80%

Et comme par magie la seconde série de donnée apparait: je vous l’avais dit…

Maintenant, à chaque choix dans les cases d’option, choisir la même couleur de données.

 

Et normalement vous aurez ce sympathique graphique.

L’origine de ce graphique:

 

Ce graphique vient de mailchimp qui représente la source du trafic dans tssperformance comme ci-dessous

Pour ceux qui auront fait attention, nos graphiques ne sont pas totalement exacts, il manque dans notre graphique le marqueur par jour (mois).

Avez-vous une idée pour rajouter les marqueurs dans ce graphique? Si vous avez des questions sur cet article ou des propositions pour rajouter les marqueurs n’hésitez pas à utiliser les commentaires pour le faire.

3 Responses to Comment vos ventes annuelles sont-elles réparties?

  1. sindezingue 2 janvier 2013 at 0 h 00 min #

    bonjour Stephane,
    graphique bien sympathique mais j’utilise Excel 2010 et je n’ai pas d’onglet « développeur » pour intégrer les ratios. As-tu une idée ?
    Merci

  2. TSS 2 janvier 2013 at 0 h 00 min #

    Salut Olivier
    Pour insérer l’onglet développeur:
    Pour Excel 2007
    Fichier/Option/Meilleur Options pour travailler avec Excel/Afficher l’onglet Développeur dans le Ruban
    Pour Excel 2010
    Fichier/Option/Personnaliser le Ruban/Cocher Développeur
    Pour Excel2003
    Affichage/Barre Outils/Formulaire

  3. Maâmoune 3 janvier 2013 at 0 h 00 min #

    Bonjour Stéphane,

    Merci pour ce tuto, c’est très joli! J’ai suivi les étapes à la lettre, mais au moment de la création du graphique, ca n’a pas marché. Quand je veux créer la deuxième série du graphique qui concerne les trois produits, un message s’affiche me disant:

     » Référence non valide. les références à des titres, valeurs, dimensions doit être une cellule, une ligne ou une colonne uniques. »

    Merci de m’expliquer ce point. Sinon, il serait de joindre le fichier excel avec votre article, ca assisterait encore plus!

Laisser un commentaire