http://tssperformance.com/wp-admin/theme-editor.php?file=content-archive-portfolio.php&theme=canvas

3 formules différentes pour retrouver les dernières cellules d’un tableau

Bonjour

Lorsqu’on travaille avec des bases de données, il peut arriver que l’on ait besoin de faire des calculs avec la dernière cellule d’une colonne: par exemple retrouver la dernière date enregistrée dans la colonne B, ou encore le dernier nom enregistré ou encore dans un tableau vous voulez faire le sommaire des totaux automatiquement.

Plus concretement prenons le tableau ci-dessous:

tab donnees

 

Notre objectif est d’avoir continuellement sur la plage B4:F4 les valeurs du dernier enregistrement. Pour résoudre nous en profiterons pour utiliser les techniques pour retrouver les derniers éléments d’un tableau.

Utiliser la fonction MAX() imbriquée dans la fonction RECHERCHEV

 

Pour en savoir plus sur la fonction RECHERCHEV, vous pouvez cliquer ici.

Pour tout savoir sur les fonctions Excel, vous pouvez cliquer ici

Dans notre cas, on va utiliser se mettre en B4 et écrire:

=RECHERCHEV(MAX($B$7:$B$1000000);$B$7:$F$1000000;1;0)

On supposera évidemment qu’on enregistre rien en dessous de ce tableau à l’exception des ventes en question.

En C4, il faudra seulement remplacer dans la formule le 1 par 2, on aura donc cette formule:

=RECHERCHEV(MAX($B$7:$B$1000000);$B$7:$F$1000000;2;0)

En D4: =RECHERCHEV(MAX($B$7:$B$1000000);$B$7:$F$1000000;3;0)

En E4: =RECHERCHEV(MAX($B$7:$B$1000000);$B$7:$F$1000000;4;0)

En F4: =RECHERCHEV(MAX($B$7:$B$1000000);$B$7:$F$1000000;5;0)

 

Il faut tout de même noter que cette formule marche uniquement parce que la 1ère colonne du tableau est remplie par des dates et classé par ordre chronologique croissant. En effet si la 1ère colonne est plutôt rempli par du texte alors cette formule ne marchera pas très bien. En fait, elle ne marchera pas du tout.

 

Utiliser la fonction NBVAL() imbriquée dans la fonction INDEX

 

Pour en savoir plus dans sur la fonction INDEX, cliquer ici

Pour tout savoir sur les fonctions Excel, vous pouvez cliquer ici

 

En B4 on écrira: =INDEX(B7:B1000000;NBVAL(B7:B1000000))

De C4 à F4 il faudra seulement incrémenter la formule, et on aura successivement:

En C4: =INDEX(C7:C1000000;NBVAL(C7:C1000000))

En D4: =INDEX(D7:D1000000;NBVAL(D7:D1000000))

En E4: =INDEX(E7:E1000000;NBVAL(E7:E1000000))

En F4: =INDEX(F7:F1000000;NBVAL(F7:F1000000))

 

Utiliser NBVAL imbriquée dans la fonction DECALER:

 

Pour avoir d’autres exemples sur la fonction DECALER, cliquer ici

Pour en savoir plus sur toutes les fonctions Excel, cliquer ici

On mettra en B4: =DECALER(B6;NBVAL(B7:B1000000);)

 

Le principe est le même que précédemment, il faudra juste incrémenter la formule sur les autres colonnes.

 

Si vous connaissez d’autres méthodes, n’hésitez pas à partager en utilisant les commentaires ci-dessous.

, , , ,

2 Responses to 3 formules différentes pour retrouver les dernières cellules d’un tableau

  1. DIARRA 10 août 2014 at 16 h 44 min #

    bonjour,
    juste vous dire que j’apprécie énormément tous les outils de gestion que vous proposez.

    • TSS 12 août 2014 at 9 h 15 min #

      @ Diarra
      Merci, je continuerai de faire de mon mieux

Laisser un commentaire